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1 Introduction to PolySpace® Products for Verifying C Code

Product Overview

In this section...

“Ensures Software Reliability” on page 1-2
“Decreases Development Time” on page 1-2

“Improves the Development Process” on page 1-3

Ensures Software Reliability

You can ensure the reliability of your C applications by using PolySpace®
verification software to prove code correctness and identify run-time errors.
Using advanced verification techniques, PolySpace software performs an
exhaustive verification of your source code.

Because PolySpace software verifies all possible executions of your code, it
can identify code that:

® Never has an error

® Always has an error

¢ [s unreachable

® Might have an error

With this information, you can be confident that you know how much of your

code 1s run-time error free, and you can improve the reliability of your code by
fixing the errors.

You can also improve the quality of your code by using PolySpace verification
software to check that your code complies with MISRA C® standards.’

Decreases Development Time

Using PolySpace verification software reduces development time by
automating the verification process and helping you to efficiently review
verification results. You can use it at any point in the development process,

1. MISRA and MISRA C are registered trademarks of MISRA Ltd., held on behalf of the
MISRA Consortium.
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Product Overview

but using it during early coding phases allows you to find errors when it is
less costly to fix them.

You use PolySpace software to verify C source code before compile time. To
verify the source code, you set up verification parameters in a project, run
the verification, and review the results. This process takes significantly less
time than using manual methods or using tools that require you to modify
code or run test cases.

A graphical user interface helps you to efficiently review verification results.
Results are color-coded:

® Green indicates code that never has an error.

Red indicates code that always has an error.
® Gray indicates unreachable code.

® Orange indicates unproven code (code that might have an error).

The color-coding helps you to quickly identify errors. You will spend less time
debugging because you can see the exact location of an error in the source
code. After you fix errors, you can easily run the verification again.

Using PolySpace verification software helps you to use your time effectively.
Because you know which parts of your code are error-free, you can focus on
the code that has definite errors or might have errors.

Reviewing the code that might have errors (orange code) can be
time-consuming, but PolySpace software helps you with the review process.
You can use filters to focus on certain types of errors or you can allow the
software to identify the code that you should review.

Improves the Development Process

PolySpace software makes it easy to share verification parameters and
results, allowing the development team to work together to improve product
reliability. Once verification parameters have been set up, developers can
reuse them for other files in the same application.

1-3
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PolySpace verification software supports code verification throughout the
development process:

¢ An individual developer can find and fix run-time errors during the initial
coding phase.
® Quality assurance can check overall reliability of an application.

® Managers can monitor application reliability by generating reports from
the verification results.



Product Components

Product Components

The PolySpace products for verifying C code are combined with the PolySpace
products for verifying C++ code. These products are:

PolySpace® Client™ for C/C++
PolySpace® Server™ for C/C++

The user interface includes:

® The Launcher for setting up verification parameters and starting
verifications.

® The Viewer for reviewing verification results.

® Spooler for managing verifications that run on a server and downloading
results from a server to a client.

1-5
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Installing PolySpace Products

In this section...

“Finding the Installation Instructions” on page 1-6

“Obtaining Licenses for PolySpace® Client for C/C++ and PolySpace® Server
for C/C++” on page 1-6

Finding the Installation Instructions

The tutorials in this guide require PolySpace Client for C/C++ and PolySpace
Server for C/C++. Instructions for installing PolySpace products are in the
PolySpace Installation Guide. Before installing PolySpace products, you must
obtain the necessary licenses.

Obtaining Licenses for PolySpace Client for C/C++
and PolySpace Server for C/C++

See “PolySpace License Installation” in the PolySpace Installation Guide for
information about obtaining licenses for PolySpace products.
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Working with PolySpace Software

In this section...

“Basic Workflow” on page 1-7
“The Workflow in This Guide” on page 1-8
“Working with PolySpace Project Model Files” on page 1-9

Basic Workflow

The basic workflow for using PolySpace software to verify C source code is:

Set up project

A 4

Verify code

A4

3
Review verification results

In this workflow, you:

1 Use the Launcher to set up a project file.
2 Verify code on a server or client.

You can use the Launcher to start the verification or you can select files
from a Microsoft® Windows® folder and send them to PolySpace software for
verification. For verifications that run on a server, you use the Spooler to
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manage the verification and download the results to a client. You can set an
option to check MISRA C compliance in the first stage of the verification.?

3 Use the Viewer to review verification results.

The Workflow in This Guide
The tutorials in this guide take you through the basic workflow, including
the different options for running verifications. The workflow that you follow

in this guide is:

Create new project

A 4

Verify code

A4

3
Review verification results

A 4

4
Check MISRA C compliance

In this workflow, you:

1 Create a new project that you use for the other steps in the workflow.

This step is in the tutorial Chapter 2, “Setting Up a Project File”.

2 Verify a single C file.

2. MISRA and MISRA C are registered trademarks of MISRA Ltd., held on behalf of the

MISRA Consortium.
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This step is in the tutorial Chapter 3, “Running a Verification”. In this

tutorial, you verify the same file using three different methods of running a
verification:

¢ Using the Launcher to start a verification that runs on a server.
e Using PolySpace In One Click to send files to a server for verification.

¢ Using the Launcher to start a verification that runs on a client.

3 Review the verification results.

This step is in the tutorial Chapter 4, “Reviewing Verification Results”.

4 Modify the project to include MISRA C checking and review the MISRA C
violations in the example file.

This step is in Chapter 5, “Checking MISRA C Compliance”.

Working with PolySpace Project Model Files

A PolySpace project model file is a project file that includes generic target
processor information. You can use this file to share project information,
but you cannot use it to run a verification. The tutorial Chapter 6, “Using a

PolySpace Project Model File” shows you how to work with PolySpace project
model files.
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Learning More

In this section...

“Product Help” on page 1-10
“The MathWorks Online” on page 1-10

Product Help

To access the help that came with your installation, select Help > Help or
click the Help icon in the PolySpace window.

To access the online documentation for PolySpace products, go to:
/www.mathworks.com/access/helpdesk/help/toolbox/polyspace/polyspace.html
The MathWorks Online

For additional information and support, see:

www.mathworks.com/products/polyspace

1-10
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Related Products

Related Products

In this section...

“PolySpace Products for Verifying C++ Code” on page 1-11
“PolySpace Products for Verifying Ada Code” on page 1-11

“PolySpace Products for Linking to Models” on page 1-11

PolySpace Products for Verifying C++ Code

For information about PolySpace products that verify C++ code, see the
following:

http://www.mathworks.com/products/polyspaceclientc/
http://www.mathworks.com/products/polyspaceserverc/

PolySpace Products for Verifying Ada Code

For information about PolySpace products that verify Ada code, see the
following:

http://www.mathworks.com/products/polyspaceclientada/
http://www.mathworks.com/products/polyspaceserverada/

PolySpace Products for Linking to Models

For information about PolySpace products that link to models, see the
following:

http://www.mathworks.com/products/polyspacemodelsl/

http://www.mathworks.com/products/polyspaceumlrh/

1-11
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e “About This Tutorial” on page 2-2

e “Creating a New Project” on page 2-3
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About This Tutorial

In this section...

“Overview” on page 2-2

“Example Files” on page 2-2

Overview

You must have a project before you can run a PolySpace verification of your
source code. In this tutorial, you create the project that you use to run
verifications in later tutorials.

Example Files

This tutorial uses the source file example.c that comes with the installation.
You learn more about the files and directories required for this tutorial in
“Preparing the Project Directories” on page 2-4.



Creating a New Project

Creating a New Project

In this section...

“What Is a Project?” on page 2-3

“Changing the Default Directory” on page 2-7

“Preparing the Project Directories” on page 2-4

“Opening the PolySpace Launcher” on page 2-5

“Creating a New Project to Verify the Example C File” on page 2-9

What Is a Project?

In PolySpace software, a project is a named set of parameters for a verification
of your software project’s source files. A project includes:

e The location of source files and include directories

® The location of a directory for verification results

® Analysis options

You can create your own project or use an existing project. You create and
modify a project using the Launcher graphical user interface.

A project file has one of the following file types:

Project Type File Extension

Description

Configuration cfg

Required for running a
verification. Does not
include generic target
processors.

2-3
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Project Type File Extension Description

PolySpace Project ppm For populating a project
Model with analysis options,
including generic target
processors.

Desktop dsk In earlier versions of
PolySpace software, for
running a verification
on a client computer.

In this tutorial, you create a new project and save it as a configuration file
(.cfg).

Preparing the Project Directories

Before you start verifying a C file with PolySpace software, you must know
the locations of the C source file and the include files. You must also know
where you want to store the verification results.

For each project, you decide where to store source files and results. For
example, you can create a project directory, and then in that directory, create
separate directories for the source files, include files, and results.

For this tutorial, prepare a project directory as follows:

1 Create a project directory named polyspace_project.

2 Open polyspace_project, and create the following directories:
® sources
® includes

® results
3 Copy the file example.c from
Install directory\Examples\Demo_C\sources

to



Creating a New Project

polyspace_project\sources

where Install directory is the installation directory.
4 Copy the files include.h and math.h from

Install directory\Examples\Demo_C\sources

to

polyspace_project\includes

Opening the PolySpace Launcher

You use the PolySpace Launcher, a graphical user interface, to create a
project and start a verification.

To open the PolySpace Launcher:

¢ Double-click the PolySpace Launcher icon.

¢ [f you have only PolySpace Client for C/C++ software installed on your
computer, skip this step. If you have both PolySpace Client for C/C++
and PolySpace Client for Ada products on your system, the PolySpace
Language Selection dialog box will appear.

£

Select a language

¥ PolySpace for CIC++

™ PolySpace for Ada

0K I Cancel
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Select PolySpace for C/C++ and click OK.

The PolySpace Launcher window appears:

Specify Specify include
source files directories
1
T
File Edit Tools Hel| |
jDom|ih X &« B||r @ = @ ;
[ 1
] - " 1
- _l _l Matne |
| Fiemame | | absalut| Path | I
W nalysis options !
—General | SpBCIfy
—TargetiCompilation ! 4
—Compliance with standards: ana lys IS
—PolySpace inner settings ! Options
—Precizion/Ecaling :
—huttitazking !
1
1
1
1
1
1
1
1
Include directaries [-ada-inclufle-dir] :
1
1
1
1
1
Files extensions [-extenzions-for-spec-files] :
. | Control
Results Directory [-results-dir] | e .
! verification
L] '
1

Compile Log

1
Send ta PolySpace Server [= 9 EA
—

| Compile : 0%
00:00:00

CDF&: 0% | Levell : 0% | Level2: 0%, Monitor
00:00:00 00:00:00 oe:oo00 | progress
I
I

Stats

Full Log
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Creating a New Project

The Launcher window has three main sections.

Use this For...
section...
Upper-left Specifying:

® Source files
® Include directories

¢ Results directory

Upper-right

Specifying analysis options

Lower

Controlling and monitoring a verification

You can resize or hide any of these sections. You learn more about the
Launcher window later in this tutorial.

Changing the Default Directory

PolySpace software allows you to specify the default directory that appears in
directory browsers in dialog boxes. If you do not change the default directory,
the default directory is the installation directory. In this tutorial, you change
the default directory to the project directory that you created in “Preparing
the Project Directories” on page 2-4. Changing the default directory to the
project directory makes it easier for you to locate and specify source files and
include directories in dialog boxes.

To change the default directory to the project directory:

1 Select Edit > Preferences.

The Preferences dialog box appears.

2-7
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x

| Remote Launcherl Miscellaneuusl Rezul direu:tnr':.fl Default direu:tu:ur':.-'l Genetic targetsl

et title I Execution cammad |

Ok Ay Cancel

2 Select the Default directory tab.
3 Select Always use this specific folder if it is not already selected.

4 Enter or navigate to the project directory that you created earlier. In this
example, the project directory is C:\polyspace project.

The Preferences dialog box should now look like the following.

2-8
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H Preferences

Tools hdenu I Remote Launcherl Miscellaneuusl Feszult directory  Default directory |

Default falder for all brovesers.

i* Alvways uze thiz specific folder |Cpolyspace_project

" Uze the current path as a default folder

(0] ,9 | Apaly | Cancel

5 Click OK to apply the changes and close the dialog box.

Creating a New Project to Verify the Example C File

You must have a project, saved with file type cfg, to run a verification. In this
part of the tutorial, you create a new project for verifying example.c.

You create a new project by:

® “Opening a New project” on page 2-10
® “Specifying the Source Files, Include Directories, and Results Directory”
on page 2-11

e “Specifying the Analysis Options” on page 2-14

® “Saving the Project” on page 2-15
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Opening a New project
To open a new project for verifying example.c:

1 Select File > New Project.

The Choose the language dialog box appears:
Bl Choose the language x|

i~ crp

(0] 4 I Cancell

2 Select C, then click OK.
The default project name, New_Project, appears in the title bar.

In the Analysis options section, the General options node expands with
default project identification information and options.
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HPnIySpace Launcher for C - New_Project -|E

File Edit Tools Help
06 W6 % 6[=alr &=
New Project 'fl _l : Searchirrternalnamefromtheselededline:I ,®|[

Mame I 'l

| Fiename | Aksollte Path

Mnalysis options
f—]—GeneraI
—Seszsion idertifier Mews Project
—Date 21/04/2008
—&uthaor YOUE PEine
—Project version 1.0

—Examine effects of scalar azsignments

—Heep all interrnediate files

—Continue even if red errors are detected

—Cartinue with the current configuration

| | o

—Cortinue even on an unsupported Linu dig
FH-TargetiCompilation

ompliance with standards

onSpace inner settings

_I Incluce directories [-] I recisiom‘ScaIing

un'rtasking

Specifying the Source Files, Include Directories, and Results
Directory

To specify the source files, include directories, and results directory for the
verification of example.c:

1 Click the green plus sign button in the upper right of the files section of
the Launcher window.

|

The Please select a file dialog box appears.

2-11
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Elrlease select a file

Look in: polyspace_project

() includes
(L0 resutts
(50 sources

I(" .z} files anly

™ Recurse subdirectories

~Source files [-sources] ~Directories to include [-1]

[~ [ [~ [

Ok Cancel

2 The project directory polyspace_project should appear in Look in. If it
does not, navigate to that directory.

3 Select the directory includes and then click the green down arrow button
in the Directories to include section.

||
The path for the directory appears in the source files list.

4 Double-click the directory sources.

5 Select the file example.c and then click the green down arrow button in
the Source files section.
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H

The path for example.c appears in the source files list.

Tip You can also drag directory and file names from an open directory
directly to the source files list or include list.

6 Click OK to apply the changes and close the dialog box.

7 In Results Directory, specify the directory for the verification results.
Enter the path for the results directory that you created earlier. In this
example, the results directory is C: \polyspace_project\results.

The files section in the upper left of the Launcher window now looks like:

2-13
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Mewy Project rl - | |

Absolute Path

File Matne

exatmple.c

| Ihclude directories [-]

- |C:'Ipculyspau:e;rnjeu:’t'l.includes

Results Directory [-results-dir]

C:lp:u:nlyspamjrnjecﬂresurtsl - |

Specifying the Analysis Options

The analysis options in the upper-right section of the Launcher window
include identification information and parameters that PolySpace software
uses during the verification process. For more information about analysis
options, see “Options Description” in the PolySpace Products for C Reference.

To specify the analysis options for this tutorial:

1 In the General section, change the Session identifier to
Example_Project.
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Note The session identifier cannot contain spaces.

2 In the General section, select the Continue even if red errors are
detected check box.

You learn about red errors in Chapter 4, “Reviewing Verification Results”.

3 Keep the default values for all other options.

Saving the Project
To save the project:

1 Select File > Save project. The Save the project as dialog box appears.

2-15
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x
Loak in: IlE:] polyspace_project LI _I ...5'

E E:j includes
. ) resutts

hily Recent D, I (e

WL
“

ol mpLter
-
Py Pty

Session idertifier | Ok

Files of type: I*_ng LI Cancel

2 In Look in, leave the default directory, polyspace_project.
3 In Session identifier, enter example.

4 In Files of type, leave the default *.cfg. You must have a project file
with type cfg to run a verification.

Note You can also run a verification with a project file of type dsk. Older
versions of PolySpace software created files with type dsk for use with a
verification running on a desktop PC. For more information about the dsk
file type, see “What Is a Project?” on page 2-3.

5 Click OK to save the project and close the dialog box.
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e “About This Tutorial” on page 3-2
® “Opening the Project” on page 3-4

e “Using the Launcher to Start a Verification That Runs on a Server” on
page 3-5

¢ “Using PolySpace In One Click to Start a Verification That Runs on a
Server” on page 3-15

e “Using the Launcher to Start a Verification That Runs on a Client” on
page 3-24
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About This Tutorial

In this section...

“Overview” on page 3-2

“Before You Start” on page 3-3

Overview

Once you have created the project example.cfg as described in “Creating a
New Project” on page 2-3, you can run the verification.

You can run a verification on a server or a client.

Use...

For...

Server

® Best performance

Large files (more than 800 lines of code including comments)

Multitasking

Client

® An alternative to the server when the server is busy

Small files with no multitasking

Note Verification on a client takes more time. You might
not be able to use your client computer when a verification is
running on it.

You can start a verification using the Launcher or using PolySpace In One
Click. With either method, the verification can run on a server or a client.



About This Tutorial

Use... For...

Launcher A basic way to start a verification.

You specify the source files in the project file.
With the project file open, you click a button to
start the verification.

PolySpace In One Click | A convenient way to start the verification of
several files which use the same verification
options.

Once you specify the project file containing the
verification options, you specify the source files
by selecting them from a Microsoft Windows
folder. You start the verification by sending the
selected files to PolySpace software.

In this tutorial, you learn how to run a verification on a server and on a
client, and you learn how to start a verification using the Launcher and using
PolySpace In One Click. You verify the file example.c three times using a
different method each time. You use:

1 The Launcher to start a verification that runs on a server.
2 PolySpace In One Click to start a verification that runs on a server.

3 The Launcher to start a verification that runs on a client.

Each verification stores the same results in polyspace_project\results.
You review these results in the tutorial Chapter 4, “Reviewing Verification
Results”.

Before You Start

Before you start this tutorial, you must complete Chapter 2, “Setting Up a
Project File”. You use the directories and project file, example.cfg, from
that tutorial.
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Opening the Project

To run a verification, you must have an open project file. For this tutorial, you
use the project file example.cfg that you created in Chapter 2, “Setting Up a
Project File”. Open example.cfg if it is not already open.

To open example.cfg:

1 If the PolySpace Launcher is not already open, open it by double-clicking
the PolySpace Launcher icon.

2 Select File > Open project.

The Please select a file dialog box opens.
3 In Look in, navigate to polyspace_project.
4 Select example.cfg.

5 Click Open to open the file and close the dialog box.
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Using the Launcher to Start a Verification That Runs on
a Server

In this section...

“Starting the Verification” on page 3-5
“Monitoring the Progress of the Verification” on page 3-7
“Downloading Results from the Server to the Client” on page 3-10

“Troubleshooting a Failed Verification” on page 3-12

Starting the Verification
In this part of the tutorial, you run the verification on a server.

To start a verification that runs on a server:

1 Select the Send to PolySpace Server check box next to the Execute
button in the middle of the Launcher window.

Send to Paly=pace Server v i’ Execute |

Note If you select Set this option to use the server mode by default
in every new project in the Remote Launcher pane of the preferences,
the Send to PolySpace Server check box is selected by default when you
create a new project.

2 Click Execute.

Note If you see the message Verification process failed, click OK
and go to “Troubleshooting a Failed Verification” on page 3-12.

The verification has three main phases:
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a Checking syntax and semantics (the compile phase). Because PolySpace
software is independent of any particular C compiler, it ensures that
your code is portable, maintainable, and complies with ANSI® standards.

b Generating a main if it does not find a main and the Generate a Main
option is selected. For more information about generating a main,
see “MAIN GENERATOR OPTIONS (-main-generator) for PolySpace
Software” in the PolySpace Products for C Reference.

¢ Analyzing the code for run-time errors and generating color-coded
diagnostics.

The compile phase of the verification runs on the client. When the compile
phase completes:

* A message dialog box tells you that the verification completed. This
message means that the part of the verification that takes place on the
client is complete. The rest of the verification runs on the server.

* A message in the log area tells you that the verification was transferred
to the server and gives you the identification number (Analysis ID) for
the verification. For this verification, the identification number is 1.

Cotmpile

Slats

' Full Log

3-6

Ciotn

Send to PolySpace Server v }/ Execute |

pile 1 00% | Intermediate : 0% Leweld : 0% | Lewvell : 0% | Lew

00:00:10 00:00: 00 00:00: 0d 00: 0000 ac

Search: 44 I (33

Status I

Descrigtion | Fite | Line | cal

1

PaolySpace Launcher for C verification start at Jan 13, 200915557

i

The analyziz has been gueued with ID="1

3 When you see the message Verification process completed, click OK
to close the message dialog box.

4 Click on any message in the log to get details about the message.

5 Stop the Launcher by clicking File > Quit.
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Monitoring the Progress of the Verification

You monitor the progress of the verification using the PolySpace Queue
Manager (also called the Spooler).

To monitor the verification of Example Project:

1 Double-click the PolySpace Spooler icon:

Spooler

The PolySpace Queue Manager Interface opens.

i Polyspace Queue Manager Interface

Cperations  Help

D | Author Application Feszultz directon CPU| Statuz | Date | Languw
wour_name  Example_Project C:\polyzpace_projectirasults anze running 008, °

Tip You can also open the Polyspace Queue Manager Interface by clicking

the PolySpace Queue Manager icon E in the PolySpace Launcher toolbar.

2 Point anywhere in the row for ID 1.

3 Right-click to open the context menu for this verification.
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Followe Progress. ..

Wigw Log File. ..

Download Results., ..

Downlaad Resulks And Remave From Quele. .,

Movwve Down In Queus

Stop &nd Download Results, ..
Stop And Remove From Quele, ..

Remove From Queue. ..
4 Select View log file.
A window opens displaying the last one-hundred lines of the verification.

" PolySpacehPolySpace_Common',Remotel auncher',whi

GUI files generation complete.

Generating remote file
Done

Certain (red? errors have hbeen detected in the analysed code dugy
SE.

Analysis continuwing bhecause the option —continue—with-red—-error

303030 -0 30 30 30 30 30 30 30 30303030 30303030 30 -3 -JE -3 —-Jof oo Jof-Jof~3af~3af~3of~3af~3af~3af~3ef~3eE-3eE-3eE-eE-3ef-ef-ef-Jof-Jef-Jef-Jef-Jef-Jef-Ief-E
Cakaiad

#3%% Leyel 4 Software Safety Analwysis done
EaXaxad

o= =Je e~ Jn e e e e e JeE 3o —eE I Jef e eI -3uE~IeE-JaE-Juf—ef e -JnE-3uE e -eE-Jaf—Jef e -JeE-JnE e e e —JaE e -eE—JnE—JeE e e Tef—JeE e -JaE-Jef e -e-Ji-Jef-Ief-e-Jei-ef
Ending at: Apr 11, 2008 12:29:8

Uzer time for pass4: 35.8real, 35.8Bu + Bs

Uzer time for poluyspace—-c: 1Y6.5real, 176.5u + Bs

CaZaZad

#*x% End of PolySpace Uerifier analysis
CaXaZad

Press enter to close the window ...

5 Press Enter to close the window.

6 Select Follow Progress from the context menu.
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PolySpace follow remote code verification progress

Help

File  Edit

A Launcher window labeled PolySpace follow remote analysis
progress for C appears.

=101

pile -

0000 0

@ Compile
% MISRA-C
m Stats

[& FullLon

P Execute |

Sendto PalyEpace Server v

6 Stop Execution |

Intermediate ;10 Tatal
00:00:15 00:00:22 00:00: 26 00;00:07 00;00; 04 00:01:36
Searchc 44 |Level 4 (13
Certain (Fed) errors summary: ;I
- certain NTC, non termination of call to example.c.Square Root, File example.c, line 240, col
- certain NTC, non termination of call ta _ polyspace  stdstubs.c.sqrt, File example.c, line 1

- certain NTC, non termination of call to exawple.c.Recursion, File example.c, line 157, colum
ILP, pointer within bounds, File example.c, line 104, column 10

AZRT, failure of user assertion, File _ polyspace_ stdstubsz.c, line 866, column 2

certain

certain

GUI files generation complete.

Generating results in a spreadsheet format in C:ZPoly3pace\Poly3pace RlDatas‘analysislyPolySpac
Generation complete

ook o ok o o o o o o o o o o o o o o o o o o o o o o o o o o o o

hEE

Fe% Software Safety Integration Analysis Lewel 4 done

.

Kl |

warification completed

You can monitor the progress of the verification by watching the progress
bar and viewing the logs at the bottom of the window. The word
processing appears under the current phase. The progress bar highlights
each completed phase and displays the amount of time for that phase.

The logs report additional information about the progress of the verification.
The information appears in the log display area at the bottom of the
window. The full log displays by default. It display messages, errors, and
statistics for all phases of the verification. You can search the full log by
entering a search term in the Search in the log box and clicking the left
arrows to search backward or the right arrows to search forward.
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7 Click the Compile Log button to display compile phase messages and
errors. You can search the log by entering search terms in the Search in
the log box and clicking the left arrows to search backward or the right
arrows to search forward.

8 Click the Stats button to display statistics, such as analysis options,
stubbed functions, and the verification checks performed.

9 Click the refresh button
Go |
to update the stats log display as the verification progresses.
10 Select File > Quit to close the progress window.
11 Wait for the verification to complete.

When the verification completes, the status in the PolySpace Queue
Manager Interface changes from running to completed.

i PolySpace Queue Manager Interface

Cperations  Help

D | Author Application Fiesultz directon CPU| Statuz | Date | Language

vour_name  Example_Project C:Apolyspace_projecthresults anze zomplete: (008, ©

Downloading Results from the Server to the Client

At the end of the verification, the results are on the server. To download the
results to your client:

1 In the PolySpace Queue Manager Interface, select Download Results
from the context menu for the verification.

The Browse For Folder dialog box appears with the
polyspace_project\results folder selected.
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Directory where ko store the results

123 Perl ;I
=) PolySpace
=l 153 polyspace_project
I includes J
I resulks
I sources
I3 PalySpace_Results -
Folder: I results

Make Mew Faolder | (o] 4 I Cancel |

4

2 Click OK to close the dialog box.

A dialog box appears telling you that the download is complete and asking
if you want to open the PolySpace Viewer.

Question X

Download completed. Do you wank bo open PolySpace Yiewer 7

Yes Mo |

3 Click No.
4 Select Remove From Queue from the context menu.

A dialog box appears asking you to confirm that you want to remove the
verification from the queue.
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Question =

Do wou really want to removwe the analvsis 1 From the queue ?

Yes Mo |

5 Click Yes.

Note

¢ To download the results and remove the verification from the queue,
select Download Results And Remove From Queue from the context
menu.

¢ [f you download results before the verification completes, you get partial
results and the verification continues.

6 Select Operations > Exit to close the PolySpace Queue Manager
Interface.

Once the results are on your client, you can review them using the PolySpace
Viewer. You review the results from the verification in Chapter 4, “Reviewing
Verification Results”.

Troubleshooting a Failed Verification

When you see a message that the verification failed, it indicates that
PolySpace software could not perform the verification. The following sections
present some possible reasons for a failed verification.

Hardware Does Not Meet Requirements

The verification fails if your computer does not have the minimal hardware
requirements. For information about the hardware requirements, see

www.mathworks.com/products/polyspaceclientc/requirements.html.


http://www.mathworks.com/products/polyspaceclientc/requirements.html
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To determine if this is the cause of the failed verification, search the log for
the message:

Errors found when verifying host configuration
You can:

e Upgrade your computer to meet the minimal requirements.

® Select the Continue with current configuration option in the General
section of the Analysis options and run the verification again.

You Did Not Specify the Location of Included Files

If you see a message in the log, such as the following, either the files are
missing or you did not specify the location of included files.

include.h: No such file or directory

For information on how to specify the location of include files, see “Creating a
New Project to Verify the Example C File” on page 2-9.

PolySpace Software Cannot Find the Server

If you see the following message in the log, PolySpace software cannot find
the server.

Error: Unknown host

PolySpace software uses information in the preferences to locate the server.
To find the server information in the preferences:

1 Select Edit > Preferences.

2 Select the Remote Launcher tab.
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x

Tools henu  Remote Launcher | Miscellaneuusl Feszult direu:tu:ur':.fl Diefault direu:tu:ur':.fl Genetic targets I

~Remote configuration

v Set this option to uze the server mode by default in every hevy project

Mate: this option iz mandatory when the project containg multitasking options.

The multitazking options will be ighared athetwize.

0 Automatically detect the remate server

' Use the folloving setver and port

The setver name "localhost" can be uzed if the server iz the local machine.

0]34 Apigaly Cancel

By default, PolySpace software automatically finds the server. You can
specify the server by selecting Use the following server and port and
providing the server name and port. For information about setting up a
server, see the PolySpace Installation Guide.
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Using PolySpace In One Click to Start a Verification That
Runs on a Server

In this section...

“Overview of PolySpace In One Click” on page 3-15
“Setting the Active Project” on page 3-15

“Sending the Files to PolySpace Software” on page 3-17

Overview of PolySpace In One Click

In a Microsoft Windows environment, PolySpace software provides a
convenient way to streamline your work when you want to verify several
files using the same set of options. Once you have set up a project file that
has the options you want, you designate that project as the active project,
and then send the source files to PolySpace software for verification. You do
not have to update the project with source file information. This process is
called PolySpace In One Click.

In this part of the tutorial, using PolySpace In One Click, you learn how to:

1 Set the active project.

2 Send files to PolySpace software for verification.

Setting the Active Project

The active project is the project that PolySpace In One Click uses to verify the
files that you select. Once you have set an active project, it remains active
until you change the active project. PolySpace software uses the analysis
options from the project; it does not use the source files or results directory
from the project.

To set the active project:

1 Right-click the PolySpace In One Click icon in the taskbar area of your
Windows desktop:
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The context menu appears.
Set active project k
Open ackive project - Example_Project

Viewer

Launcher

7 & T

Spoaler
Help »

Exit

2 Select Set active project > Browse from the menu.

The Please set an active project dialog box appears:
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Please set an active project. d |

Laak i I&} polvzpace_project j 4= fji v

includes
resulks
S0UFCES

Cia example.cfg

L

Open

Cancel

File narne: || j
=

il

Filez of type: IF'cul_l,ISpace configuration files

3 In Look in, navigate to polyspace_project.
4 Select example.cfg.

5 Click Open to apply the changes and close the dialog box.

Sending the Files to PolySpace Software
You can send several files to PolySpace software for verification. For this
tutorial, you send one file, example.c.

To send example.c to PolySpace software for verification:

1 Navigate to the directory polyspace _project\sources.
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2 Right-click the file example.c.
The context menu appears.

[ame |

Lol

Open
Edit
Cpen with \WordPad
ca Scan For viruses, .,
Cpen YWith »
£l WinZip 3

Send To b

Cuk
Copy

Create Shortout
Delete
F.enames

Properties

3 Select Send To > PolySpace.
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Marme | Size | Tvpe
ot SKE CFile
Open
Edit
Cpen with WordPad
2 Scan for viruses, ..
Cpen Wikh »
&) WinZip 3
£ ] Compressed (zipped) Folder
uk @ Desktop (create shorbout)
apy [ Fax Destination via RightFax
reate Shortouk (# Macromedia FreeHand M
Delete

| Mail Recipient
Rename
,D MMy Documents

Properties FalySpace

4L 314 Floppy (A2)

The PolySpace basic settings dialog box appears.
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Settings

Precision

Passes

Parameters

Results directory |C:\polyspace_projel:t\results |
Function called before main | |
Main generator write variables INone j
Scope

Chvpolyspace_projectysourcesiexample.c

[ [+

¥l Send to PolySpace Server @ EHecutel @ Cancell

4 Make sure that Results directory is polyspace project\results.
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Parameters

Results directory |C:"~.|:u:-|1,rs|:-ace_prnject"xresults |

Function called before main | |

Main generator write variables INl:une vI

5 Select the Send to PolySpace Server option if it is not already selected.

6 Leave the default values for the other parameters.
Click Execute.

The verification log appears.
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E:"-.,pulyspace _projecti results Example_Project.log

HEE O @ -

[FFuRchon Fandom_tiost 1= pUre . REtUFnE an ntisized valle.
Generating the Main ...

Zenerating call to function: RTE

Doing code transformations .

£33

=5 C zources verification done
E++4

[ [Endling at: ksy 13, 2008 53220
|I=er time for suif: 54real, 5.4u + 0=
- |Zenerating remate file

. [Done

=er time for polyspace-c: 5.8real, 5.5u + Oz
EE+3

*** End of PolySpace Verifier analysis

£33

Ldding the analysis to the gqueue ..
Tranzfering the archive to the server ..

Tranzfer completed.
Aralysiz D1

The analysiz has heen gqueusad. You may followy ts progress using the spoaler.

al |

|The analyziz haz been succeszsfully done

The compile phase of the verification runs on the client. When the compile
phase completes:

® You see the message:
End of PolySpace Verifier analysis

® A message in the log area tells you that the verification was transferred
to the server and gives you the identification number (Analysis ID) for the
verification. For this verification, the identification number is 1.
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e Monitor the verification using the Spooler. For information on using the
Spooler to monitor a verification on a server, see “Monitoring the Progress
of the Verification” on page 3-7.

® When the verification completes, download the results to
polyspace _project\results. For information on downloading results
from a server to a client, see “Downloading Results from the Server to the
Client” on page 3-10

You review the results in Chapter 4, “Reviewing Verification Results”.
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Using the Launcher to Start a Verification That Runs on a

In this section...

“Starting the Verification” on page 3-24
“Monitoring the Progress of the Verification” on page 3-25
“Completing the Verification and Stopping the Launcher” on page 3-26

“Stopping the Verification Before It Completes” on page 3-27

Starting the Verification

For the best performance, run verifications on a server. If the server is busy
or you want to verify a small file, you can run a verification on a client.

Note Because a verification on a client can process only a limited number
of variable assignments and function calls, the source code should have no
more than 800 lines of code.

To start a verification that runs on a client:

1 Open the Launcher if it is not already open.
2 Open the project file example.cfg if it is not already open.

For information about opening a project file, see “Opening the Project”
on page 3-4.

3 Make sure that the Send to PolySpace Server check box is clear.

4 If you see a warning that multitasking is not available when you run
a verification on the client, click OK to continue and close the message

box. This warning only appears when you clear the Send to PolySpace
Server check box.

5 Click the Execute button.
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},‘f Execute |

6 If you see a caution that PolySpace software will remove existing results
from the results directory, click Yes to continue and close the message
dialog box.

The progress bar and logs area of the Launcher window become active.

Note If you see the message Verification process failed, click OK
and go to “Troubleshooting a Failed Verification” on page 3-12.

Monitoring the Progress of the Verification

You can monitor the progress of the verification by watching the progress bar
and viewing the logs at the bottom of the Launcher window.

Send to PolvSpace Server | B Exccute |

Carnpile | 90% | Irtermediste ; 0% ‘ Leweld : 0% ‘ Lewvell : 0% | Leve
00:00:01 00:00:00 00:00:00 00:00:00 ool

Cnmpile search; 44 | (13
B wsrac | staus Description | File | Lne | co

Stat= I. |F‘DI\,-'Space Launcher for C werifi... | | |

+ FulLog

The progress bar highlights the current phase in blue and displays the
amount of time and completion percentage for that phase.

The logs report additional information about the progress of the verification.
To view a log, click the button for that log. The information appears in the
log display area at the bottom of the Launcher window. Follow the next steps

to view the logs:

1 The compile log displays by default.
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This log displays compile phase messages and errors. You can search the
log by entering search terms in the Search in the log box and clicking the
left arrows to search backward or the right arrows to search forward.

2 Click the Stats button to display statistics, such as analysis options,
stubbed functions, and the verification checks performed.

3 Click the refresh button
Go |
to update the display as the verification progresses.

4 Click the Full Log button to display messages, errors, and statistics for all
phases of the verification.

You can search the full log by entering a search term in the Search in
the log box and clicking the left arrows to search backward or the right
arrows to search forward.

Completing the Verification and Stopping the
Launcher

When the verification completes, a message dialog box appears telling you
that the verification is complete and asking if you want to open the Viewer.
For this tutorial, do not open the Viewer at this point.

S x|
@ Yerification process completed,
Do wiou wank to launch PolySpace Viewer

Cancel |

To indicate that you do not want to open the Viewer:
¢ (Click Cancel.

You can also open the Viewer from the Launcher toolbar, but for this tutorial,
you do not do this. For this tutorial, close the Launcher.
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To close the Launcher:
® Select File > Quit.

In the tutorial Chapter 4, “Reviewing Verification Results”, you open the
Viewer and review the verification results.

Stopping the Verification Before It Completes

You can stop the verification before it completes. If you stop the verification,
results will be incomplete, and if you start another verification, the verification
starts over from the beginning.

To stop a verification:

1 Click the Stop Execution button.

@ Stop Execution |

A warning dialog box appears.

waming x|

@ Do wou really want to stop the current execution ?

o |

2 Click Yes.

The verification stops and the message Verification process stopped
appears.

3 Click OK to close the Message dialog box.
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Note Closing the Launcher window does not stop the verification. To resume
display of the verification progress, open the Launcher window and open the
project that you were verifying when you closed the Launcher window.
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Results

e “About This Tutorial” on page 4-2

® “Opening the Viewer and the Verification Results” on page 4-3
¢ “Exploring the Viewer Window” on page 4-5

* “Reviewing Results in Expert Mode” on page 4-9

® “Reviewing Results in Assistant Mode” on page 4-28

e “Automatically Testing Unproven Code” on page 4-35

® “Generating Reports of Verification Results” on page 4-36
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About This Tutorial

In this section...

“Overview” on page 4-2

“Before You Start” on page 4-2

Overview

In the previous tutorial, Chapter 3, “Running a Verification” , you completed a
verification of example.c. In this tutorial, you explore the verification results.

PolySpace Client for C/C++ provides a graphical user interface, called the
Viewer, that you use to review results. In this tutorial, you learn:

1 How to use the Viewer, including how to:

® Open the Viewer and open verification results.

Select the Viewer mode.

Explore results in expert mode.

Explore results in assistant mode.

® Generate reports.

2 How to interpret the color-coding that PolySpace software uses to identify
the severity of an error.

3 How to find the location of an error in the source code.

Before You Start

Before starting this tutorial, be sure to complete the tutorial Chapter 3,
“Running a Verification”. In this tutorial, you use the verification results in
this file:

polyspace_project\results\RTE_px_02_Example_Project_ LAST_RESULTS.rte.
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Opening the Viewer and the Verification Results

In this section...

“Opening the Viewer” on page 4-3
“Selecting the Viewer Mode” on page 4-3

“Opening the Results” on page 4-4

Opening the Viewer

You use the Viewer to review verification results. Open the Viewer if it is
not already open.

To open the Viewer:

® Double-click the PolySpace Viewer icon:

Note You can also open the Viewer from the Launcher by clicking the Viewer
icon in the Launcher toolbar with or without an open project.

Selecting the Viewer Mode

You can review verification results in expert mode or assistant mode:

® In expert mode, you decide how you review the results.

¢ In assistant mode, PolySpace software guides you through the results.

You switch from one mode to the other by clicking a button in the Viewer
toolbar. For this part of the tutorial, the Viewer should be in expert mode.
If the Viewer is in expert mode, the mode button in the toolbar displays
Assistant.
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G pssistant

If the Viewer is not in expert mode, click the mode button to switch to expert
mode.

~'1§.'-‘ Expert |

You learn more about expert and assistant modes later in this tutorial.

Opening the Results

To open the verification results:

1 Select File > Open.

2 In the Please select a file dialog box, navigate
to polyspace_project\results and select the file
RTE_px_02_Example_Project_LAST_RESULTS.rte.

3 Click the Open button.

The results appear in the Viewer window.

Note The file RTE_px_02_Example_Project_ LAST_RESULTS.rte represents
the verification with the highest level of precision. The lower level results files
that you see in the polyspace _project\results directory represent lower
precision verifications.
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Exploring the Viewer Window

In this section...

“Overview” on page 4-5

“Reviewing the Procedural Entities View” on page 4-7

Overview
The PolySpace Viewer looks like:

Coding review progress view Selected check view

-Poly'Space Yiewer - C:\polysglace_projectiresults'RTE_px_02_Example_Project_LAS

Fil= Edit ‘Windows Help
£

J 5 B = m| <8 & 9 i J N-SHR: QJ & ﬂﬁ“uwefined - G assistant

JIRauiewadfilteroff vl X ¥ v N ||onn| zou |,gg§, gﬁ?tllnp |COR oW | RY SHF |°{‘r{g,|ulp TLORT ASRT  NTC  KNTC

-loix]

Coding review progress Court Pr...l Ma check currently selected
Mo check selected hia hia A|
b reviesved I nb to reviesy (nfa) iz nia |
||Software reliability ndicator nia  nia LI [} al

Procedural entities

4
p [ variables Yie I=l|{EEICall Tree Yie al

4
L
Example_Project

B polyspace_stdst

|$—4pol\rspace7main.c

Iﬁ—examp\e.c

- polyspace_ stdstubs o fWiritten by 1

* Eoth
Read by 3
i Called by 4
iritten by task 1|
" calls »
Read by task 113
[~ complete

Potentially Written by

[¥ Update on selection
Potertially Read by

[ =|0l ]

4 | ]

Procedural Variables  Source code  Call tree
entities view view view view
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The appearance of the Viewer toolbar depends on the Viewer mode. Because
the Viewer is in expert mode, the expert mode toolbar displays.

a2 [ o |1 J N-3HR %VJ < TLLEJIUndefined ~| & pssistant

NIV

FLOAT
ather | HIF RZRT  WTC  K-NTC

Zou COR POk IRY SHF OUFL

WIN  SCAL
local  OUFL I 7

In both expert mode and assistant mode, the Viewer window has six sections
below the toolbar. Each section provides a different view of the results. The
following table describes these views.

This view...

Displays...

Procedural entities view (lower left)

List of the diagnostics (checks) for
each file and function in the project

Source code view (lower right)

Source code for a selected check in
the procedural entities view

Coding review progress view (upper
left)

Statistics about the review progress
for checks with the same type and
category as the selected check

Selected check view (upper right)

Details about the selected check

Variables view

Information about the global
variables declared in the source code

Note The file that you use in
this tutorial does not have global
variables.

Call tree view

Tree structure of function calls

You can resize or hide any of these sections. You learn more about the Viewer

window later in this tutorial.
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Reviewing the Procedural Entities View

The procedural entities view, in the lower-left part of the Viewer window,
displays a table with information about the diagnostics for each file in the
project. The procedural entities view is also called the RTE (run-time error)
view. When you first open the results file from the verification of example.c,
the procedural entities view looks like:

Procedural entities

1 Example_Project

o s

%——_pu:-h,rspace_main.c
J:p-—example e

Jln-—_p-:-h,rspace_stdstuhs R

The file example.c is red because its has a run-time error. PolySpace software
assigns a file the color of the most severe error found in that file. The first
column of the table is the procedural entity (the file or function). The following
table describes some of the other columns in the procedural entities view.

Column Indicates

Heading

| 2 I Number of red checks (for operations where an error always
- occurs)

Number of gray checks (for unreachable code)

Number of orange checks (warnings for operations where
an error might occur)

KRNI

Number of green checks (for operations where an error
never occurs)

Total number of red, green, and gray checks (an indication
of the level of proof)

L
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Tip If you see three dots in place of a heading, J, resize the column until you
see the heading. Resize the procedural entities view to see additional columns.

Note You can select which columns appear in the procedural entities view
by editing the preferences. To learn how to add a Reviewed column, see
“Making the Reviewed Column Visible” on page 4-14.

What you select in the procedural entities view determines what displays in
the other views. In the following examples, you learn how to use the views
and how they interact.



Reviewing Results in Expert Mode

Reviewing Results in Expert Mode

In this section...

“What Is Expert Mode?” on page 4-9

“Switching to Expert Mode” on page 4-9
“Reviewing Checks in Expert Mode” on page 4-9
“Reviewing Additional Examples of Checks” on page 4-17

“Filtering the Types of Checks That You See” on page 4-22

What Is Expert Mode?

In expert mode, you can see all checks from the verification in the PolySpace
Viewer. You decide which checks to review and in what order to review them.

Switching to Expert Mode

If the Viewer is in expert mode, the mode toggle button displays Assistant. If
the Viewer is in assistant mode, the mode toggle button displays Expert. To
switch from assistant to expert mode:

e (Click the Viewer mode button:

~'§.'.‘ Expert

The Viewer window toolbar displays buttons and menus specific to expert
mode.

Reviewing Checks in Expert Mode

In this part of the tutorial, you learn how to use the Viewer window views to
examine checks from a verification. This part of the tutorial covers:

e “Selecting a Check to Review” on page 4-10
® “Displaying the Calling Sequence” on page 4-11
e “Tracking Review Progress” on page 4-12

® “Making the Reviewed Column Visible” on page 4-14
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Selecting a Check to Review

In the procedural entities view, example.c is red, indicating that this file has
at least one red check. To review a red check in example.c:

1 In the procedural entities section of the window, expand example.c.
2 Expand the red procedure Pointer Arithmetic().

A color-coded list of the checks performed on Pointer Arithmetic()
appears:

Bl o erscibmetic ()
= WA
—® WA
o OWFLA
" LUNFL.5
— # 1oP.1
3 0WFLA4
L% UMNFL1S
3 UHR.16
e W0ATT
L UMNFL2Z
- OWFLI2E
L UHFLIG

Each item in the list of checks has an acronym that identifies the type

of check and a number. For example, in IDP.11, IDP stands for Illegal
Dereferenced Pointer. For more information about different types of checks,
see “Check Descriptions” in the PolySpace Products for C Reference.

3 Click the red IDP.11.

The source code view displays the section of source code where this error
occurs.
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92 int i, ¥p = array;

a3

94 for(i = 0; 1 «< 100; ii+])
a5 {

a5 no= 0;

97 i

95 i

99

1nn if{get bus= =status=()] > 0)
101 {

103 [

10& 1

106 else

107 {

108 i++;
1049 3

110 1

4 At line 104 of the code, click the red code.

= example.c

10z if(get oil pressure(] > 0]

104 *_p = L /¥ ut of bounds */

An error message box displays indicating that when the pointer p is

dereferenced, it is outside of its bounds. At line 92, p points to the start of
array which has 100 elements. The for loop starting at line 94 initializes
the elements of array to 0. This for loop leaves p pointing to the location

after the last element of array.

Displaying the Calling Sequence

You can display the calling sequence that leads to the code associated
with a check. To see the calling sequence for the red IDP.11 check in

Pointer_Arithmetic():

1 Expand Pointer_Arithmetic().

2 Click the red IDP.11.
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3 Click the call graph button in the toolbar.
&

A window displays the call graph.

!Errnr call graph for example.Pointer_Arithmetic.IDP.11 - PolySpace ¥iewe

polyspace_main.c example.c example.c example.c

main RTE

Fointer Arithmetic IDF.11

The code associated with IDP.11 is in Pointer_ Arithmetic. The generated
main function calls RTE, which calls Pointer_ Arithmetic.

Tracking Review Progress

You can keep track of the checks that you have reviewed by marking them. To
mark that you have reviewed the red IDP.11 check in Pointer_ Arithmetic():

1 Expand Pointer_Arithmetic().

2 Click the red IDP.11.

A table with statistics about the review progress for that category and
severity of error appear in the upper-left part of the window.
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I Coding revievy progress Count Progress

Inb IDP revieweed Jnkb IDP to reviewy (Red) iyl 1]

linb reviewved 1 nb ta review [Fed) 0r4 1]
=oftweare reliabilty indicator 93115 an

The Count column displays a ratio and the Progress column displays the
equivalent percentage. The first row displays the ratio of reviewed checks
to total checks having the color and category of the current check. In this
example, it displays the ratio of reviewed red IDP checks to total red IDP

errors in the project.

The second row displays the ratio of reviewed checks to total checks having
the color of the current check. In this example, this is the ratio of red errors
reviewed to total red errors in the project. The third row displays the ratio
of the number of green checks to the total number of checks, providing an

indicator of the reliability of the software.

Information about the current check (the red IDP.11) appears in the

upper-right part of the Viewer window.

example .o ! Pointer _Arithimetic §line 104 5 column 10

=] *n o= 57 /% 0ut of bounds */

=

rror @ pointer iz outszide itz bounds

3 Select the check box to indicate that you have reviewed this check. You can

enter a comment in the comment box.

The Coding review progress part of the window updates the ratios of

errors reviewed to total errors.

]
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I Coding reviesy progress Count Progress

Inb IDP reviensed !k IDP to reviewy (Red) il 100
Inb reviewed fnb to revieww (Red) 104 25
ISDﬂware relisbility indicetor 93115 a0

Making the Reviewed Column Visible
You can change the PolySpace Viewer preferences so that the procedural
entities part of the window displays a Reviewed column.

1 Select Edit > Preferences.

2 Select the Table options tab.

3 Under Display columns in RTE view, select the Reviewed check box.

Now the Table options tab looks like:
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HPrEferences PolySpace Yiewer

Tools Wenu  Takle options | Toolbars Dptiu:unsl hizcellansous

~Dizplay columnz in BTE wiew

v Gray

v Qrange

v Green

IV Lire

v Calurnt

¥ Tatal Selectivity

¥ Detailz

|- Camments

~Dizplay columns ariable

[¥ M read

[+ Mo write

v Wiiting Tasks
v Reading Tasks
[+ Protection

| Uzage

¥ Line

I+ Colurn

[ File

v Detailed Type

v walues

4 Click OK to apply the preference and close the dialog.

A column of check boxes appears in the Procedural entities view.
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Frocedural entities 13| 7|+ Line | ...| % | Detailz | Reviewed
Iﬁ Ezample_Project 4 |7 | a2 -
[#—__palyspace_main.c 1 0 [ paby... |-
[H—example.c 4 | 7 i 1 82 xampl... r
B |37 |12 |40 exampl.. -
[H—Men_Infinite_Loop 4 G 11 100 xampl... |-
[H—Puainter_Arthmetic [ 1 3 b o] 12 | 90 exampl... |_
L WD a4 |6 r
" WA o4 |22 r
— OWF L4 1 94 |23 [+ o ... r
" LHFLS 1 a4 |23 [+] und... |_
—+ 1 104 |10 | pointer .| [+
—3 OwFLi4 1 s |11 [+] o |_
—3 UMHFLAS 1 g (11 [+] und... |_
3 UNR.16 1 s 1 r
— W07 1z | 2 r
- LINFL.ZZ 1 114 [ 16 [Flund... |_
— % Ha |18 Flove.| [

The check box for IDP.11 in Pointer_ Arithmetic() is selected because you
selected the check box for this diagnostic in the current check view (upper-
right part of window).

Tip If you do not see this column, resize Procedural entities so that you see
the column. Resize the column to see the Reviewed label.
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Note Selecting a check box in the Reviewed column automatically:
® Selects the check box for that check in the current check view (upper-right
part of the window).

e Updates the counts in the coding review progress view (upper-left part
of the window).

Reviewing Additional Examples of Checks
In this part of the tutorial, you learn about other types and categories of

errors by reviewing the following examples in example.c:
e “Example: Unreachable Code” on page 4-17

e “Example: Arithmetic Error” on page 4-18

e “Example: A Function with No Errors” on page 4-19

¢ “Example: Division by Zero” on page 4-20

Example: Unreachable Code

Unreachable code is code that never executes. PolySpace software displays
unreachable code in gray. In the following example, you look at an example
of unreachable code.

1 In Procedural Entities, click Unreachable Code().

The source code for this function displays in the source code view.
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1949
200
201
202
203
204
205
20a
207
208
209
210
211
212
213
214
215

Weoroec - =il

= example.c

static woid Unreachable Codewoid)

{

_."'*

*
int

int ¥ =

it

{

(x >

Here we demonstrate Polyipace Verifier's ability to
identify unreachable sections of code due to the
value constraints placed on the wvariables,

® = random int():
randow int{);

¥l

-y

{x < 0]

X =%+ L

2 Examine the source code.

At line 212, the code x = x +1 is never reached because the condition x
< 0 is always false.

Example: Arithmetic Error
In the following example, PolySpace software detects a memory corruption

error:

1 In Procedural entities , expand the red Square_Root () function.

The source code for this function displays in the source code view.
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=
179 atatic woid Square Root _conw (double alpha, float *heta pr)
1a0 A% Perform arithmetic conwersion of alphia to beta */

151 {

182 Fheta pt = (float]) ((1.5 + cosfalpha)) s 5.0);

183 3

la4

1585 gtatic woid Square Foot (woid)

186 {

1587 double alpha = random £loat();

158 float heta:

159 float ganma;

lan

191 Fmuare FHoot_conv (alpha, sbeta):

192

193 gawma = [floatjsgritibeta - 0.75); A* always sqrtinegative
104 1

1hAE

2 Examine the source code.

Because beta is always less than 0.75, the argument to the sqrt () function
at line 193 is always negative.

Example: A Function with No Errors

In the following example, PolySpace software determines, in code with a large
number of iterations, that a loop terminates and a variable does not overflow:

1 In Procedural entities, click the green Non_Infinite Loop() function.

The source code for this function displays in the source code view.
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BE gtatic int Non Infinite Loop (woid)
67 { const int big = 1073741821 ; /% 2%¥%30-3 +/
G int x=0, ¥=0;

69

70 while [1)

71

Tz {

73 if (¥ » big) { break:}

T o=H ot Z:

75 ¥o=ux S 2

TG 1

77

75 ¥ ==/ 100;

79 return ¥;

&0 1

2 Examine the source code. The variable x never overflows because the while
loop at line 70 terminates before x can overflow.

Example: Division by Zero
In the following example, PolySpace software detects division by zero:

1 In Procedural entities, expand Recursion().

The source code for this function displays in the source code view.
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137
135
133
140
141
14z
143
144
145
l4a
147
145
149
150
151
132
153
154
155
158
157
158
159
la0
lal
laz
1a3
lad
las

=

static wolid Recursion (int* depth)
% 1if depth<0, recursion will lead to division by =zero */
{ float adwvance:

#depth = *depth + 1:
adwance = 1.0£/(float) (¥depth); /% potential division by zero */

if {*depth < 50)
{

Becursion(depth) ;

'

static woid Recursion_calleriwoid)
{ int x=random int(]:

if ([(xx-4) &6 (X < -1]]
{

Becursion( &x ! A4 oalways encounters a divizion by zero

¥ = 10;
if (random int{) = 0)
{

Recursion( &x ! A% never encounters a division by zero ¥4

2 Examine the Recursion() function.
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When Recursion() is called with depth less than zero, the code at line
142 will result in division by zero. The orange color indicates that this is a
potential error (depending on the value of depth).

3 Examine the red Recursion_caller function.

The first call to Recursion() at line 157 is red because it calls
Recursion() with depth less than zero, causing a division by zero. The
second call to Recursion() at line 164 does not cause division by zero
because it calls Recursion() with depth greater than zero.

Filtering the Types of Checks That You See

You can filter the checks that you see in the Viewer so that you can focus

on certain types of checks. PolySpace software provides three predefined
composite filters, a custom composite filter, and several individual filters. You
learn about filters in the following sections:

¢ “Using Composite Filters” on page 4-22

¢ “Using the Custom Filter” on page 4-24
¢ “Using Individual Filters” on page 4-26

Using Composite Filters

Composite filters combine individual filters, allowing you to display or hide
groups of checks.

Use this filter... To...

Alpha Display all checks

Beta Hide NIV, NIVL, NIP, Scalar OVFL,
and Float OVFL checks

Gamma Display red and gray checks

User def Hide checks as defined in a custom
filter that you can modify

The default filter is User def. You learn more about the User def filter in
“Using the Custom Filter” on page 4-24. You select a composite filter from
the filter menu.
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User def TI

Filter all
Alpha
Beta
Zamma
Undefined

To learn how the composite filters affect the display of checks:

1 Select Alpha from the filter menu to display all the checks for
Square_Root ().

Square_Root ()has eight checks: five green, one red, and two gray.

[H—5quare_FRoot ()
- 0an
R
- MIWLE
3 OWFL3
3 UNFL4
— § NTC.S
" NIVLE
L UOWFLY

2 Select Beta from the filter menu to hide the NIV, NIVL, NIP, Scalar OVFL
and Float OVFL checks.

[E—Square_Rcu:it [
| v vsn

| I—V’ IR

I L4 ntcs

Now, only three checks are visible: one VOA, one IRV, and one NTC.
3 Select Alpha to display all checks again.

4 Select Gamma to display only the red and gray checks.
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-3¢ owrLa

-3¢ unrLa

qa—Square_R-:n:-t ]
|
|
| L% nmcs

Now, only three checks are visible: one red and two gray.

Using the Custom Filter

The custom filter is a composite filter that you define. It appears on the
composite filter menu as User def and is the default composite filter. By
default, the custom filter hides the OBAI, NIV local, IDP, COR, IRV, NIV
other, NIP, and NTL checks as shown in the following figure.

W E  [CALLs .
N-ZHR ':g é:' 1_ JIUserdef "I {_§'.‘ Fessistant

| opAl  zow [(MIY O SERL D opp | cor  pow | mw  seE | RTY O fowe FRRET pser wTe kT

lacal

To modify the custom filter:

1 Select User def from the composite filters menu.
2 Select Edit > Custom filters.

The Custom filter setup dialog box appears.
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ntustom filter setup - PolySpace Yiewer

Select the checks or colors ta hide when the custam filter is set

Check Filters Colar Fiters “ariable Type Fiters
IV out : Index Checks I Gray Checks I™ Mon-Shared Variables
™ Zern Division Checks r Crange Checks
[+ Mon-Initislized Local Vatishle Checks [ Green Checks
I Scalar Overflowy Checks I~ Errors in non executable procedures
v llegal Dereferenced Pointer Checks r Crange not containing additional information

[V Correctness Condition Checks
I~ Power must be positive Checks
[+ Initislized Returned Yalue Checks
I shift Amount ot of Bounds or Left Operand of Left Shift Checks
Float [ Scalar Fitters

¥ Non-Initislized Yariable Checks

I™ Float Checks
[+ Mon-Initislized Poirter Checks

I Flost Overflow Checks (W ety B
™ User Agsertion Checks

I Unknawn Non-Termination of Call Checks

I Known Non-Termination of Call Checks

[V 1on-Termination of Loop Checks

[ Unreachable Code Checks

I~ walug On Assigned (only displayed, not courted)

Ok | Spply | Cancel |

3 Clear the filters for the checks that you want to display. For example, if you
clear the Out of Bound Array Index Checks box, these checks display.

Note You do not have to change any of the selections for this tutorial.

4 Select the filters for the checks that you do not want to display.

5 Click OK to apply the changes and close the dialog box.

PolySpace software saves the custom filter definition in the Viewer
preferences.
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Using Individual Filters

You can use an individual filter to display or hide a given check category,
such as VOA. When a filter is enabled, that check category does not display.
For example, when the VOA filter is enabled, VOA checks do not display.
When the filter is disabled, that check category displays. For example, when
the VOA filter is disabled, VOA checks display. You can also filter by check
color. To enable or disable an individual filter, click the toggle button for that
filter on the toolbar.

Tip The tooltip for a filter button tells you what filter the button is for and
whether the filter is enabled or disabled.

To learn how an individual filter affects the display of checks:

1 Expand Square_Root ().
2 Select Alpha from the composite filters menu to display all checks.

3 Click the IRV filter button

IRW

to hide the IRV check for Square_Root ().

[H—%quare_Root ()
g %080
e HIWLZ
3 OwFLZ
3 UMFL4
— § HTC.E
" HIvLG
L UOWFLT

4 Click the IRV filter button again to display the IRV check.

5 Click the green checks filter button
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~

to hide the green checks.

d}l—Square_Ft-:n:-t [
| ¢ ovrLa

| -3¢ unrLe
| L wrcs

Note When you filter a check category, some red checks with that category
display. For example, if you filter IDP checks, IDP.11 still displays under
Pointer_Arithmetic().
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Reviewing Results in Assistant Mode

In this section...
“What Is Assistant Mode?” on page 4-28

“Switching to Assistant Mode” on page 4-28

“Selecting the Methodology and Criterion Level” on page 4-29
“Exploring Methodology for C” on page 4-29

“Reviewing Checks” on page 4-31

“Defining a Custom Methodology” on page 4-33

What Is Assistant Mode?

In assistant mode, PolySpace software chooses the checks for you to review
and the order in which you review them. PolySpace software presents checks
to you in this order:

1 All red checks

2 All blocks of gray checks (the first check in each unreachable function)

3 Orange checks according to the selected methodology and criterion level

You learn about methodologies and criterion levels in “Selecting the
Methodology and Criterion Level” on page 4-29.

Switching to Assistant Mode

If the Viewer is in assistant mode, the mode toggle button displays Expert. If
the Viewer is in expert mode, the mode toggle button displays Assistant. To
switch from expert mode to assistant mode:

. ‘ G pssistant
e (Click the Viewer mode button

The Viewer window toolbar displays controls specific to assistant mode.
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JIMethndnlngy for Model Based Designedj r— |_ Skip gray chechks 4 <§ '@}' §> [
1 2 a

The controls for assistant mode include:

® A menu for selecting the review methodology for orange checks
e A slider for selecting the criterion level within that methodology
¢ A check box for skipping gray checks

® Arrows for navigating through the reviews

Selecting the Methodology and Criterion Level

A methodology is a named configuration that defines the number of orange
checks, by category, that you review in assistant mode. Each methodology
has three criterion levels. Each level specifies the number of orange checks
for a given category. The levels correspond to different development phases
that have different review requirements. To select the methodology and level
for this tutorial:

1 Select Methodology for C from the methodology menu.

ethodalogy for C LI
Methodaology for Ada

Methodaology for ©
Methodaology for C++
Methodalogy for Model Based Designed

2 If the level slider is not already at 1, move the slider to level 1.

J—

1 2 3

Exploring Methodology for C

In this part of the tutorial, you examine the configuration for Methodology
for C. To examine the configuration for Methodology for C

1 Select Edit > Preferences.
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The Preferences PolySpace Viewer dialog box appears.

2 Select the Assistant configuration tab.

The configuration for Methodology for C appears.

On the right side of the dialog box, a table shows the number of orange
checks that you review for a given criterion and check category.

ameous | Assistant configuration i

—Mumber of checks to review:

Criterion 1 Criterion 2 Criterion 3
CComman
il 3 20 AL
P 10 S0 AL
S-O%FL |10 =0 AL
CoR 10 10
POy = 10 AL
Pl l 10
F-O%FL |5 10 20
ASRT 5 20
i & CHt anly
CE&| 10 20 AL
SHF 5 10 L
P 10 20
P 10 20
i anly
IR = 20 AL
4+ anly 1

For example, the table specifies that you review five orange ZDV checks
when you select criterion 1. The number of checks increases as you move
from criterion 1 to criterion 3, reflecting the changing review requirements
as you move through the development process.
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In the lower-left part of the dialog box, the section Review threshold
criterion contains text that appears in the tooltip for the criterion slider
on the Viewer toolbar (in assistant mode).

Configuration set

hethodalogy for C LI

Review threzhaold criterion

Criterian 1 Fresh code
Criterion 2 it tested
Criterion 3 Code reviesny

For the configuration Methodology for C, the criterion names are:

Criterion Name in the Tooltip
1 Fresh code

2 Unit tested

3 Code Review

These names correspond to phases of the development process.

3 Click OK to close the dialog box.

Reviewing Checks
In assistant mode, you review checks in the order in which PolySpace software
presents them:

1 All reds

2 All blocks of gray checks (the first check in each unreachable function)

Note You can skip gray checks by selecting the Skip gray checks check
box in the toolbar.
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3 Orange checks according to the selected methodology and criterion level

Earlier in this tutorial, you selected Methodology for C, criterion 1. In this part
of the tutorial, you review the checks for example.c using this methodology
and criterion. To navigate through these checks:

1 Click the forward arrow 2 .

In the procedural entities view (lower left), RTE() expands and NTC.3 is
the current check.

Procedural entities |

ﬁ MNew_Project
[H—example.c
b—Pointer_sdithmetic ( )
tB-RTE ()
B

i——Recursi-:-n_caller [

i——Squar&_Rnut [

The source code view (lower right) displays the source for this check and
the current check view (upper right) displays information about this check.

Note You can display the calling sequence and track review progress as
you did in “Reviewing Results in Expert Mode” on page 4-9.

2 Continue to click the forward arrow until you have gone through all of
the checks.

After the last check, a dialog box appears asking if you want to start again
from the first check.
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Wrapping search x|

@ End of the set of checks under review,
Do wou want to start again From the First check?

3 Click No.

Defining a Custom Methodology

You cannot change the predefined methodologies, such as Methodology for
C, but you can define your own methodology. In this part of the tutorial, you
learn how to create and use your own methodology.

The methodology that you create is the Methodology for C with one change.
To define your custom methodology:
1 Select Edit > Preferences.
The Preferences PolySpace Viewer dialog box appears.
2 Select the Assistant configuration tab.
3 Select Add a set from the menu in Configuration set.

4 In the Create a new set dialog box, enter My methodology for the name
and click Enter to close the dialog box.

5 Under the Criterion 1 column, enter the number 1 next to IDP. This tells
PolySpace software to select up to one orange IDP for review.

6 Click OK to save the methodology and close the dialog box.
To use My methodology:

1 Select My methodology from the methodology menu.

2 If the level slider is not already at 1, move the slider to level 1.
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3 Click the forward arrow ? to review the checks.

With this methodology at criterion 1, you review the orange IDP.20 (you
did not review IDP.20 earlier in the tutorial because the number of orange
IDP checks in Methodology for C, criterion 1 is zero).

4 End PolySpace Viewer by selecting File > Quit.
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Automatically Testing Unproven Code

Reviewing orange code to find true errors is time-consuming. You can use the
Automatic Orange Tester (AOT) to automatically create and run test cases to
identify errors in the orange code. The workflow for using the AOT is:

1 Set an option to indicate that you want to prepare automatic tests.

2 Run the verification to prepare the tests and verify the source code.

3 When the verification is finished, run the test cases.

4 Review the results.

To learn how to use the AOT, see “Automatically Testing Orange Code” in the
PolySpace Products for C User’s Guide.
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Generating Reports of Verification Results

Generating a Report of the example.c Verification

You can generate a Microsoft Excel® report of the verification results. To
generate an Excel report of the verification results for example.c:

1 Navigate to polypace_project\results\PolySpace-Doc.
The directory should have the following files:

Example Project_Call Tree.txt
Example_Project_RTE_View.txt

Example Project_Variable_View.txt
Example_Project-NON-SCALAR-TABLE-APPENDIX.ps
PolySpace_Macros.xls

The first three files correspond to the call tree, RTE, and variable views
in the PolySpace Viewer window. For more information about the Viewer
window, see “Exploring the Viewer Window” on page 4-5.

2 Open the macros file PolySpace Macros.x1s.
A security warning dialog appears.
3 Click Enable Macros.

A spreadsheet appears. The top part of the spreadsheet looks like:
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apply filkers? ——————— Generate checks by file?
& Mo filters & yes
" Beta filters  ho

Hal n | Yse this button to create the complete synthesis in one file.
=elect the RTE expoart view and a file in which to save results.
If the other views are in the same directory as the RTE wiew
then they will automatically be incorporated into the same file.

Hel n

Generate Poly=Space Results Synthesis

4 In the top half of the spreadsheet, in Apply filters?, select No filters.
5 In Generate checks by file?, select yes.
6 Click Generate PolySpace Results Synthesis.

The synthesis report combines the RTE, call tree, and variables views into
one report.

The Where is the PolySpace RTE View text file dialog box appears.
7 In Look in, navigate to polypace_project\results\PolySpace-Doc.
8 Select Example Project RTE View.txt.
9 Click Open to close the dialog box.

The Where should I save the analysis file? dialog box appears.

10 Keep the default file name Example Project-Synthesis and file type
Microsoft Excel Workbook(*.xls)

11 Click Save to close the dialog box and start the report generation.

Microsoft Excel opens with the spreadsheet that you generated. This
spreadsheet has several worksheets:
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:I Example_Project-Synthesis.xls

}||

Call Graph of ll tree

all tree
__poly=space_main.main
| - » ezample.RTE
| | - » example.Close_To Zero
|| ] » pet_stubs 0. random_ float
|| ] » pst_stubs 0. random_ float
| ] » pst_stubs 0. .random_int
| | > exanple. Hon_Infinite Loop
| | - » ezxample.Pointer Arithmetic
| 1 | » pet_=stubs_0.g=et_bus =status
|| ] » exanple.get_oil pressure
|| ] » pst_stubs 0.get_bus status
| | - » example.Recursion_caller
| 1 | » pet_=stub=s_0.random_int
| | | - » ezample.Recursion
| | | | =% RecursiwveCall to exanple. Recursion:
|| ] » pet_stubs 0. .randomn_int
| | | - » example.Recursion

Already displaved abowve

» p=t_=tub=s 0.random_int
» example . Square_FRoot
» pet_=tub=s 0.random_float
— » example.Sguare_Root_conwv

» TeEtern.sgrt
» example . Unreachable Code
» pet_=tub=s 0.random_int

| » pet_stub=s_0.random_int
b [ Application Call Tree / Shared Globals 4  Global Data Dictionary £ Checks by file

|
|
| ] » Textern.cos
|
|

PR TR Y AU Y S U Y Y ) R R Ry ey PR PR P ) Y g

12 Select the Check Synthesis tab to view the worksheet showing statistics
by check category:
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B Example_Project-Synthesis.xls

&, B C|ID|E|F

1 RTE Statistics

2 | Check category Check detail R O Gy
3 |0BAI Out of Baunds Array Index 000
4 MWL Uninitialized Local Variable 012
5 |IDF llegal Dereference of Pointer (1 |1 |0
B [MIP Lninitialized Paointer 0o
7 M Lninitialized Yariable 0o
a8 |1 Initialized Yalue Returned 0o
g |COR Other Correctness Conditions 0 0 0
10 |ASET User Asgertion Failure 010
11 | PO FPower Must Be Positive 000
12 [Z0% Division by Zero 010
13 | SHF Shift Amount YYithin Bounds 0o
14 |CWFL Creerflow o2 \3
15 |LINFL Lnderfl o ono|3
16 |LIOWFL Underflow or Cverflow 030
17 |EXCP Arithrmetic Exceptions 000
18 |MTC Mon Termination of Call 300
19 |k-NTC Known Mon Termination of Call /0 0 0
20 |MTL Mon Termination of Loaop 000
21 |LUMRE Unreachable Code 0o
22 | LIMP Uncalled Procedure 0o
23 |IPT Inspection Point 000
24 |OTH other checks 0o
25 |ERC Exception handling 0on
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5 Checking MISRA C® Compliance

About This Tutorial

In this section...

“Overview” on page 5-2

“Before You Start” on page 5-2

Overview

PolySpace software can check that C code complies with MISRA C 2004
standards.? To check MISRA C compliance, you set an option in your project
and then run a verification. PolySpace software finds the violations during
the compile phase of a verification. When you have addressed all MISRA C
violations, you run the verification again.

In this tutorial, you learn how to:
1 Set an option for checking MISRA C compliance.

2 Select MISRA C rules to check.

3 Run a verification with MISRA C checking.

Before You Start

For this tutorial, you check the MISRA C compliance of the file example.c,
using the project that you created in Chapter 2, “Setting Up a Project File”.

3. MISRA and MISRA C are registered trademarks of MISRA Ltd., held on behalf of the
MISRA Consortium.
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Setting Up MISRA C Checking

In this section...

“Opening the Example Project” on page 5-3

“Setting the MISRA C Checking Option” on page 5-4
“Creating a MISRA C Rules File” on page 5-4

“Excluding Files from the MISRA C Checking” on page 5-8
“Configuring Text and XML Editors” on page 5-8

“Saving the Project with a New Name” on page 5-9

Opening the Example Project

For this tutorial, you modify the project in example.cfg to include MISRA
C checking and save the project with a new name.* You use the Launcher
to modify the project.

To open the Launcher:
® Double-click the Launcher icon.
To open example.cfg:

1 Select File > Open project.

The Please select a file dialog box opens.
2 In Look in, navigate to polyspace_project.
3 Select example.cfg.

4 Click Open to open the file and close the dialog box.

4. MISRA and MISRA C are registered trademarks of MISRA Ltd., held on behalf of the
MISRA Consortium.
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Setting the MISRA C Checking Option

You set up MISRA C checking by selecting an option and then selecting the
rules to check. To set the MISRA C checking option:

1 In the analysis options part of the Launcher window, expand the
Compliance with standards option.

2 Select the Check MISRA-C:2004 rules check box.
3 Expand the Check MISRA-C:2004 rules option.

Two options, Rules configuration and Files and directories to ignore,
appear.

fEI—Check MISRA-C: 2004 rules r

—Rules configuration

—Files and directaries ta ighore

These options allow you to specify which MISRA C rules to check and
which, if any, files to exclude from the checking.

Creating a MISRA C Rules File

You must have a rules file to run a verification with MISRA C checking. You
can use an existing file or create a new one. You create a new rules file for
this tutorial by:

® “Opening a New Rules File” on page 5-4
e “Setting All the Rules to Off” on page 5-5
e “Selecting the Rules to Check” on page 5-5

Opening a New Rules File
To open a new rules file:

1 Click the button I_I to the right of the Rules configuration option.

A window for opening or creating a MISRA C rules file appears.
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2 Select File > New File.

A table of rules appears. For each rule, you specify one of these states:

State Causes the verification to...

Error End after the compile phase when
this rule is violated.

Warning Display warning message and
continue verification when this rule
1s violated.

Off Skip checking of this rule.

Note The default state for most rules is Warning. The state for rules that
have not yet been implemented is Off. Some rules always have state Error
(you cannot change the state of these).

Setting All the Rules to Off

Because this tutorial checks only a few rules, first set the state of all rules to
Off. Later, you select the rules to check.

To set the state of all rules to Off:

1 From the Set the following state to all MISRA rules menu, select Off .
2 Click Go.

Selecting the Rules to Check
To select the rules to check for this tutorial:
1 Expand the set of rules named 16 Functions.

2 Select the Error column for 16.3.

3 Expand the set of rules names 17 Pointers and Arrays.
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4 Select the Warning column for 17.4.

The completed rules table looks like:
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Rules Errar IWarning Off I

MIZRA Crules

I—Numl::ner of rules by mode : 7 1 134

Ervironnerit

2 Language extenszions

3 Documentation

Character zets

Identifiers

Types

I-' Constants

Declarations and definitions

Initiali=ation

0 Arithmetic type conversions

1 Painter type conversions

? Exressions

3 Cantrol statement expressions

4 Cortrol flowy

5 Swyitch statements

f—]—’l G Functions
—16.1 Functionz shall nat be defined with variable numbers of arguments. f" - o
—16.2 Functions shall nat call themselves, either directly or indirectly. f" - o
—16.3 ldentifiers shall he given for all of the parameters in & function prototy o - f"
—16.4 The identifiers used in the declarstion and defintion of a function shall C 2
—16.2 Functions wvith ho parameters shall be declared with parameter type f" f" o
—16.6 The number of arguments passed to a function shall match the numbe f" f" o
—I16.7 & pointer parameter in a function protatype should be declared as poi f" « g
—16.5 Al exit paths from a function with non-void return type shall have an ¢ r ':H o
—16.9 & function identifier shall only be used with either a preceding & or f" f" o
—1 G610 If & function returns error information, then that error information sha © © g

=17 Pointer and arrays
—17.1 Pointer arithmetic shall only be applied to pointers that address an arrs © © g
—17.2 Pointer subtraction shall only be applied to pointers that address elems © © g
—17.3 =, == = == shal not be applied to pointer types except where they po © © g
—17.4 Array indexing shall be the only allowed form of poirter arithmetic. f" o f"
—17.5 The declaration of objects should contain no more than 2 levels of poi f" f" o
—17 6 The address of an ohject with automstic storage shall not be azsigne r i "

[+18 Structures and unions

9 Preprocessing directives

2IZI Standard libraries

[#-21 Rur-time failures

5-7
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5 Click OK to save the rules and close the window.
The Save as dialog box opens.
6 In File, enter misrac.txt

7 Click OK to save the file and close the dialog box.

Excluding Files from the MISRA C Checking

You can exclude files from MISRA C checking. You might want to exclude
some included files. To exclude math.h from the MISRA C checking of the

project example.cfg:

1 Click the button I—I to the right of the Files and directories to ignore
option.

2 Click the folder icon.

=l

The Select a file or directory to include dialog box appears.
3 Navigate to the directory polyspace project\includes.
4 Select the file math.h.
5 Click OK.

The file math.h appears in the list of files to ignore.

6 Click OK to close the dialog box.

Configuring Text and XML Editors

Before you check MISRA® rules, you should configure your text and XML
editors in the Viewer. Configuring text and XML editors in the Viewer allows
you to view source files and MISRA reports directly from the MISRA-C log in

the viewer.

To configure your text and .XML editors:
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1 Select Edit > Preferences.
The Preferences dialog box opens.
2 Select the Editors tab.

The Editors tab opens.

H Preferences

Toolz henu I Remnte | auncher
Miscelaneais I Rezult directory | Default directory I

Generic targets

X

~HML editar configuration
Specify the full psth to a XML editor or use the brawse buttan.

WML Editar: IC:'I.F‘ngram Filez"M=0tficelDifice! XEXCEL EXE _)l

~Text editar configuration

Specify the full path to a text editor ar use the browese button.

Text Edlitor: IC:'I.F‘ru:ugram FilesWindows NTWCcessoriesweordpad exe _)l

Specify the command line arguments for the text editor,

Arguments: I

The fallowing macros can be uzed FFILE, 3LIMNE, FCOLLIMN

Ol Apply Cancel

3 Specify an XML editor to use to view MISRA-C reports.

4 Specify a Text editor to use to view source files from the Viewer logs.

5 Click OK.

Saving the Project with a New Name

You save the project with a new name so that you do not modify example.cfg.
To save the project with the name misra_example.cfg:

1 Select File > Save as new project.
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2 In the Save the project as dialog box, navigate to polyspace_project.
3 Enter misra_example for the Session identifier and *cfg for the type.

4 Click OK to close the dialog box.
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Running a Verification with MISRA C Checking

In this section...

“Starting the Verification” on page 5-11
“Examining the MISRA C Log” on page 5-12
“Opening MISRA-C Report” on page 5-15

Starting the Verification

When you run a verification with the MISRA C option selected, the verification
checks most of the MISRA C rules during the compile phase.’

Note Some rules address run-time errors.

The verification stops if there is a violation of a rule with state Error.

To start the verification:

. F Execute |
1 Click the Execute button .

2 If you see a caution that PolySpace software will remove existing results
from the results directory, click Yes to continue and close the message
dialog box.

The verification fails because of MISRA C violations. A message dialog
box appears.

5. MISRA and MISRA C are registered trademarks of MISRA Ltd., held on behalf of the
MISRA Consortium.
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P

@ Werification process Failed

3 Click OK.

Examining the MISRA C Log
To examine the MISRA C violations:

1 Click the MISRA-C button in the log area of the Launcher window.

A list of MISRA C violations appear in the log part of the window.

Compile Search: 44 | (43
T
’*’"SR*E‘-C Status| Rule | Fle | lne | cal
Stats T 63 |includeh 33 0
@ Ul L T ofra Example.c a7 0
W P95 [i7a lewemplec 114 0
T lra lexamplec 115 0

2 Click on any of the violations to see a description of the violated rule, the
full path of the file in which the violation was found, and the source code
containing the violation.

Search: 44 I 13

Dretail
inciude b X} I
% [7a ample.c a7 0 Rule: 16.3 (Error): Identifiers shall be giwven for all of the parameters in a
T [74 |examplec 114 0
F Hra exarmple.c 115 0 File: C:\PolySpace\polyspace_projectiincludesiinclude.h line 33 (column 0)

Source code

5-12




Running a Verification with MISRA C® Checking

The log reports a violation of rule 16.3. A function prototype declaration in
include.h is missing an identifier.

3 Right click the row containing the violation of rule 16.3 , then select Open
Source File.

Status | Rule File: Likne Cal L_
?

17 .4 Exarmp 4= Open Source File

174 EXarmp Open MISE.A-C Report

174  lexamp i Configure Editor

The include.h file opens in your text editor.

Note You must configure a text editor before you can open source files.
See “Configuring Text and XML Editors” on page 5-8.
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include.h - WordPad -0 x|

File Edit View Insert Format Help

D= SR s i=@o| B

#ifndef INCLUDE H =
#define INCLUDE H

$define true 1
$define false O

$define checksum 1
#define new mowve O
$define previous move 1

#define MAX SIZE 10

S#% automatically stubbed functionz */

extern volid SEND MESSAGE (int status, const char *message) !
extern int read bus status(void):;

extern int error on bus(void);

extern int read on bus(void):

/# internal function=z #/

void initialise current data(void):;
volid compute new coordonates (void):;
void sort calibration(void):

int polynomia (int inpuat);

int random int (wvold) ;

float random float (void):

extern void partial init(int *new alt);

extern vold RTE (void):

extern volid Exec One Cycle (int); ;I
A

For Help, press F1

4 Correct the MISRA violation and run the verification again.

The verification will complete, and the results will be the same as those
from the tutorial in Chapter 3, “Running a Verification”.
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Opening MISRA-C Report
After you check MISRA rules, you can generate an XML report containing all
the errors and warnings reported by the MISRA-C checker.

Note You must configure an XML editor before you can open a MISRA-C
report. See “Configuring Text and XML Editors” on page 5-8.

To view the MISRA-C report:

1 Click the MISRA-C button in the log area of the Launcher window.
A list of MISRA C violations appear in the log part of the window.

2 Right click any row in the log, and select Open MISRA-C Report.

Status| Rule File Line Col L_
?

17 .4 Exarmp %= Open Source File

17.4 e xamp Open MISRA-C Report

17 .4 Bxamp  wd Configure Edikar

The report opens in your XML editor.
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Cin \d9-© ' = Book2 - Microsoft Excel Table Tools =aERt
S ) ) i
‘ Home l Insert Page Layout Formulas Data Review View Add-Ins Acrobat Design @ - =7 X
E * Calibri E‘Wrap Text General = ﬁ @ Bt - ﬂ [ﬁ
B I Delete - -
Paste =i Merge & Center Conditional Format — Cell || . sort & Find &
7 EZ 2 Formatting ~ as Table ~ Styles - @Formatv A7 Filter~ Select—
Clipboard ™= Alignment Mumber Styles Cells Editing
Nameld Modeﬂ
16.3 required error C: \PoIvSpaoe\polyspaoeJ)rOJect\mcludes\lnclude h 33 0| Identlflers shall be given for all of the parameters in a function protc
17.4 required warning example.c 97 0 | Array indexing shall be the only allowed form of pointer arithmetic.
17.4 required warning example.c 114 0 | Array indexing shall be the only allowed form of pointer arithmetic.
17.4 required warning example.c 118 0 | Array indexing shall be the only allowed form of pointer arithmetic.
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About This Tutorial

In this section...

“Overview” on page 6-2

“Before You Start” on page 6-2

Overview

A PolySpace project model file provides a way to save generic targets with
project information. Although you can populate a project with information,
such as source files and project options, from a project model file, you cannot
run a verification with a project model file. You must have a configuration file
to run a verification. In this tutorial, you learn how to:

1 Create a new project model file.

2 Define a generic target and save it in the project model file.
3 Create a configuration file from a project model file.

4 Delete a generic target from the Launcher preferences.
Before You Start

Before you start this tutorial, you must complete Chapter 2, “Setting Up a
Project File”to learn about configuration files and basic Launcher operations.
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Creating a New PolySpace Project Model File

In this section...

“What Is a PolySpace Project Model File?” on page 6-3
“Creating the PolySpace Project Model File” on page 6-3

What Is a PolySpace Project Model File?

A PolySpace project model file is a project file that includes generic target
processors. A development team uses this file to share project information.
The workflow is:

1 A team leader creates a project model file (. ppm). This file has the analysis
options for the project, including generic targets.

2 The team leader distributes the .ppm file to the team.

3 A developer opens the .ppm file. From this file, PolySpace software
populates the project parameters and the generic targets in the preferences.

4 The developer adds source files, include directories, and a results directory
to the project and saves it as a configuration file (.cfg).

5 The developer launches a verification with the.cfg file.

Creating the PolySpace Project Model File

You use the PolySpace Launcher to create a PolySpace project model file.
Creating a project model file involves:

® “Opening a New Project” on page 6-4

¢ “Examining the Preferences Before Adding the Generic Target” on page 6-4
¢ “Defining the Generic Target” on page 6-5

¢ “Examining the Preferences After Adding the Generic Target” on page 6-7
® “Saving the PolySpace Project Model File” on page 6-8
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Opening a New Project
To open a new project:

1 Open the PolySpace Launcher by double-clicking the Launcher icon on
your desktop.

2 If the PolySpace Language Selection dialog box appears, select
PolySpace for C/C++ and click OK.

3 Select File > New Project.
4 In the Choose the language dialog box, select C and click OK to close
the dialog box.

Examining the Preferences Before Adding the Generic Target

In this step, you look at the generic targets in the preferences before you add
a generic target. Unless you previously added a generic target, the generic
targets list 1s empty. Later, after you add a generic target, you look at the
generic targets in the preferences again, and see that the generic target that
you added is in the list.

To look at the generic targets in the preferences:

1 Select Edit > Preferences.

The Preferences dialog box appears.
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x

| Remote Launcherl Miscellaneuusl Result direu:tnr':.fl Detault direu:tu:ur':.-'l ZEnetc targetsl

et title I Execution cammad |
| |

Ok Ay Cancel

2 Select the Generic targets tab.

Unless you previously added generic targets to your preferences, the
generic targets list is empty.

3 Click Cancel to close the dialog box.

Defining the Generic Target
To define a generic target:

1 In Analysis options, expand Target/Compilation.

2 Click the down arrow to open the Target processor type menu.
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SPArc =]

mGSk

PO ErIC

i356

c-167

32005
sharc21x61
necyEsl

b5

b2

FfICSy

----P=T Generic----
rcpu. .. [Advanced)

3 Select mcpu... (Advanced).

The Generic target options dialog box appears.
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Hﬁeneric target options El

Enter the target name ||

Default result of siored right shitt  |rithmetical (Default) =

dhitz  16hits  3Zbitz  Gdhits

Char v [ o =V sigred
Short [ ) i o
It o G " e
Lok i i ) f"
Lonhg long i i i i
Flot o r v e
Doubledong double [ e i« &
Painter o O] [ o
Aligrinert i i (o i
Save Carncel

4 In Enter the target name, enter target1.
5 Click Save to save the generic target options and close the dialog box.

Examining the Preferences After Adding the Generic Target

Now when you look at the generic targets in the preferences, you should see
the generic target that you added. To look at the generic targets list in the
preferences:

1 Select Edit > Preferences.
The Preferences dialog box appears.

2 Select the Generic targets tab.
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Notice that target1 appears in the generic targets list:

target

Eclit

Remove

3 Click Cancel to close the dialog box.

Saving the PolySpace Project Model File
To save the PolySpace project model file:

1 Select File > Save project.

The Save the project as dialog box appears.
2 Select *.ppm from the Files of type menu.
3 In Session identifier, enter target_example.

4 Click OK to save the file and close the dialog box.

Warning The generic target that you defined in this tutorial
remains in your preferences until you delete it. Be sure to complete
the section “Deleting a Generic Target from the Preferences” on page

6-12 at the end of this tutorial.
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Creating a Configuration File from a PolySpace Project
Model File

In this section...

“Why You Must Have a Configuration File” on page 6-9
“Opening the Project Model File” on page 6-9
“Entering Additional Required Information” on page 6-10

“Saving the Configuration File” on page 6-10

Why You Must Have a Configuration File

In the first part of this tutorial, you created a project model file. To run a
verification, you must have a configuration file. In this part of the tutorial,
you create a configuration file from the project model file that you created
earlier. The workflow is:

1 Open the project model file. Opening the project model file populates the:

® Generic targets in the preferences

® Analysis options and other project information

2 Enter additional information, such as the results directory and source files.

Note If you enter the results directory and source files in the project before
you save it as a PolySpace project model file, then that information is saved
in the file and appears in the project when you open the file.

3 Save the configuration file.

Opening the Project Model File

To open the project model file:

1 Select File > Open project.

The Please select a file dialog box appears.
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2 Navigate to the polyspace_project directory.
3 In File of type:, select Project Model (*.ppm) files from the menu.
4 Select target_example.ppm and click Open.

A message appears telling you that this project has no source files.

5 Click OK to close the message dialog box.

Entering Additional Required Information
A configuration file must specify the source files and results directory.

To complete the required project information:

¢ In Results Directory, enter the results directory that you created. For
the example in this guide, it is C: \polyspace _project\results.
e Add C:\polyspace project\sources\example.c to the source files.

® Add C:\polyspace project\includes to the include directories.

Note For more information about adding source files and include directories
to a project, see “Creating a New Project to Verify the Example C File” on
page 2-9.

Saving the Configuration File
To save the configuration file:

1 Select File > Save project.

The Save the project as dialog box appears.
2 Navigate to the polyspace_project directory.
3 In Session identifier, enter example2.

4 Leave the default type as *.cfg.
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5 Click OK to save the project and close the dialog box.

Note Your preferences still include the generic target target1 . Complete
“Deleting a Generic Target from the Preferences” on page 6-12 to delete this

generic target from your preferences.
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Deleting a Generic Target from the Preferences

In this section...

“Understanding the Generic Targets Preference” on page 6-12

“Deleting the Generic Target Added in This Tutorial” on page 6-12

Understanding the Generic Targets Preference

The list of generic targets is stored as a PolySpace software preference. You
can add generic targets to the list in one of these ways:

e Edit the preferences using the PolySpace Launcher.
¢ Open a PolySpace project model file that includes generic targets.

The generic targets remain in your preferences until you delete them.
You should delete the generic target that you defined and added to your
preferences earlier in this tutorial.

Deleting the Generic Target Added in This Tutorial

To delete the generic target target1 from your preferences:

1 In Analysis options, expand Target/Compilation.

2 If Target processor type is targetl, change it to sparc (You cannot
delete a generic target if it is the target processor type for the current
project.)

3 Select Edit > Preferences.

The Preferences dialog box appears.

4 Select the Generic targets tab.

5 Select target1 from the list.

6 Click Remove.

7 Click OK to apply the change and close the dialog box.
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Note You removed the generic target target1 from your preferences,
but it is still in target_example.ppm. If you save the current project in
target_example.ppm, then target example.ppm will no longer include
targeti.
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